TV Forums

Free Games Games Forums Music Forums TV Forums

  Main Index FORUM
HOME
Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN
Rules & FAQ RULES
F.A.Q.

Crumbtrail TV Forums: TV Equipment: TV Repair Forum: Yes Backlight no picture, replaced main board, non-existant t-con?: Edit Log



tvnewbie23
New User

Feb 9, 2020, 6:38 AM


Views: 400
Yes Backlight no picture, replaced main board, non-existant t-con?

Model: TCL Roku 49s405

Powers on, has full backlight. No image. No sound coming from main 3 HDMI inputs when I stick in a chromecast, though who knows if this thing is just sitting on a roku menu or something. Buttons on the bottom generate sound but they're likely hard-wired.

I open up the back. Components look good. I replace the main board. Same exact issue. So I'm thinking it's the t-con except.... I can't seem to find it. I trace the ribbon cable from the main board down to the bottom of the TV and it connects to a very thin (1-2cm) board that runs the entire length of the TV under an additional metal shield. Doesn't look like a t-con board. Can't find a replacement online. Is this thing built into the video board? How do I further troubleshoot?

In summary: yes backlight, no video, unknown sound, video board already replaced and did not fix.

Please and thank you.


(This post was edited by tvnewbie23 on Feb 9, 2020, 6:33 PM)



Edit Log:
Post edited by tvnewbie23 (New User) on Feb 9, 2020, 6:33 PM


Search for (options) - Page loaded in: 0.10 s on (CGI/1.1)