Crumbtrail TV Forums: TV Equipment: TV Repair Forum:
Vizio VF550M not turning on?



kourso1
New User

Jul 30, 2020, 4:53 AM


Views: 163
Vizio VF550M not turning on?

The Vizio VF550M HDTV will not turn on.
The amber VIZiO logo light remains on while attempting to turn it on with the power button. The logo light is suppose to turn to white when the TV turns on.
I have tried unsuccessfully to do a TV power reset by unplugging the power cord & pressing the power button down for 10 sec.
The TV screen stays black as well.
I tried unsuccessfully changing inputs & pressing the menu button.
What is possible & what is the cause is this problem. Prior to the TV going our, the TV screen would go to a “no signal” blue screen & it also couldn’t be remotely operated?
The TV also lost the audio immediately before it crashed.
Would this be the power board or the main control board. Audi got all of these issues? Please advise what I can cecheck/test. Thanks guys



kourso1
New User

Jul 31, 2020, 1:06 AM


Views: 148
Re: [kourso1] Vizio VF550M not turning on?

Can anybody help me with this Vizio TV problem? Trying to determine what circuit board needs to be replaced? Thanks


jts1957
Veteran


Jul 31, 2020, 9:55 PM


Views: 135
Re: [kourso1] Vizio VF550M not turning on?

I'm leaning towards the Main. Crazy


-------------------------
Location: Far, Far Away


kourso1
New User

Aug 1, 2020, 3:12 AM


Views: 130
Re: [jts1957] Vizio VF550M not turning on?

Just asking, what is the biggest reason it may be the main board? i’m just trying to better understand TV repair. What would be the approx cost to buy & replace the main board,
Could I possibly swap the boards myself? Are these boards readily available for this model?
Thank you JTS !


jts1957
Veteran


Aug 1, 2020, 8:25 AM


Views: 127
Re: [kourso1] Vizio VF550M not turning on?

You indicate that your TV has power.
The Main board contains a microprocessor and EEPROM where the instructions for booting up the TV are stored. EEPROMs are easily corrupted.

Examples of symptom(s) of a corrupted EEPROM:

HDMI ports do not work
Audio does not work
Vizio logo is always blinking
TV does not turn on
TV turns on but does not load past on screen Vizio logo then shuts off


-------------------------
Location: Far, Far Away

(This post was edited by jts1957 on Aug 1, 2020, 8:28 AM)


kourso1
New User

Aug 1, 2020, 6:48 PM


Views: 117
Re: [jts1957] Vizio VF550M not turning on?

The Vizio logo stays constant lit as an amber color.
The logo normally turns to white as the TV comes on.
The TV screen stays black & does not light.
I have also tried to change inputs & press on the menu panel button with no success.
You can hear a slight power hum when you plug in to ac power. And there is no response from pressing the power panel button. Immediately prior to the TV crash, it was not responding to the remote control for power on/off. The TV also lost all audio & was going randomly to a blue screen “no signal” screen.
When you pull the power cord off of the TV, there is like a power pop/click on the unpowering.
What is the availability of a main board part?
Can a DIY’er do it? How difficult is it to replace?
And what is the approx. part cost?
Do you think the TV is feasible to repair?
Thanks for your help!


(This post was edited by kourso1 on Aug 1, 2020, 6:52 PM)


jts1957
Veteran


Aug 1, 2020, 10:02 PM


Views: 85
Re: [kourso1] Vizio VF550M not turning on?

Here are just two (of?) options:

https://www.nickstvs.com/store/p2136/VF550M.html
https://www.ebay.com/...graded-/264081371661

All you gave me to work with are the brand / model / symptom ... Mad
It's your set / your wallet / your decision.


-------------------------
Location: Far, Far Away

(This post was edited by jts1957 on Aug 1, 2020, 10:07 PM)


kourso1
New User

Aug 2, 2020, 2:32 PM


Views: 63
Re: [jts1957] Vizio VF550M not turning on?

I looked at the options that you listed.
Just don’t know how successful the repair kit would be & it requires some soldering work.
And not sure if I can invest $125 on the TV main board repair & then hope the TV works properly again.
I really appreciate your help on this issue.
Thanks JTS