TV Forums

Free Games Games Forums Music Forums TV Forums

  Main Index FORUM
HOME
Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN
Rules & FAQ RULES
F.A.Q.

Crumbtrail TV Forums: TV Equipment: LCD TV Forum:
Vizio 37" no picture, just colored vertical lines

 

 


jdaviestx
New User

Jul 7, 2014, 7:46 PM

Post #1 of 3 (1606 views)
Shortcut
Vizio 37" no picture, just colored vertical lines Can't Post

I have a Vizio 37" TV that I kept outside (in a covered location), that died on me last weekend. It powers on - I can see the "Vizio" emblem at the bottom turn white and if I peek down the back, I see that the backlight turns on. However, I get no picture (on any input, HDMI, AV1, nothing) - I just get a series of five or six bands of vertical lines.

So - it's definitely not the power board, so that leaves the mainboard or the LCD display itself. As I understand it, if the LCD has gone bad, there's nothing I can do to fix it. But if it's the mainboard, I can buy a new one online for like $80. So my question to you experts, before I fork over $80, is... do these symptoms sound like a broken LCD or a bad mainboard?



jts1957
Veteran


Jul 7, 2014, 8:29 PM

Post #2 of 3 (1603 views)
Shortcut
Re: [jdaviestx] Vizio 37" no picture, just colored vertical lines [In reply to] Can't Post

NO Inverter or Tcon boards?Unimpressed


-------------------------
Location: Far, Far Away


jdaviestx
New User

Jul 7, 2014, 8:33 PM

Post #3 of 3 (1600 views)
Shortcut
Re: [jts1957] Vizio 37" no picture, just colored vertical lines [In reply to] Can't Post

Nope - the Tcon board is part of the mainboard (which is why the replacement costs $80 instead of $30). If I open the thing up there are only two PCBs - the one on the left is clearly the power and the one on the right is the mainboard.

 
 
 


Search for (options) - Page loaded in: 0.16 s on (CGI/1.1)