TV Forums

Free Games Games Forums Music Forums TV Forums

  Main Index FORUM
HOME
Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN
Rules & FAQ RULES
F.A.Q.

Crumbtrail TV Forums: TV Equipment: LCD TV Forum:
Samsung LE32R73BD Fault

 

 


dannypot
New User

Jan 7, 2020, 1:13 PM

Post #1 of 1 (692 views)
Shortcut
Samsung LE32R73BD Fault Can't Post

OK, so here goes.

I suspect I have a T-CON board fault but wanted other opinions before I deal with it.

Model is above in the subject line.


Symptoms:

It can work for hours without a glitch but then randomly the colour goes all weird - random bright colours in stripes down the screen.

A few seconds into the weird colour, lines will appear vertically down the screen and the screen will slowly fade to black.

Sound still works and the backlight is clearly on and working normally as the screen is lit up.

If I turn it off at the mains and then back on again, it tends to go back to normal 7 out of 10 times but the fault then re-occurs anything from a few minutes to a couple of hours later on. Usually happens more often when the house is warmer.

On the occasions where power-cycling it doesn't resolve the issue, I find that I can see fading colours on the screen in the lines that appear until the image goes blank again but last night was the strangest one - I left it on for a while after the 3rd power cycle and it started working normally again for a good couple of hours until I set it back to standby.

Given the nature of the lines appearing and the fact that it can go from working to not working without warning, I suspect that it is the t-con board suffering an intermittent failure in one of the control chips (I can see no damage to any boards in the TV other than a bit of dust here and there, no bulging or blown capacitors anywhere and all connections are secure and fitted properly).


 
 
 


Search for (options) - Page loaded in: 0.15 s on (CGI/1.1)