TV Forums

Free Games Games Forums Music Forums TV Forums

  Main Index FORUM
HOME
Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN
Rules & FAQ RULES
F.A.Q.

Crumbtrail TV Forums: TV Equipment: TV Repair Forum:
Samsung UA75JU6400WXXY - dark side of screen

 

 


MC89
New User

Aug 1, 2021, 1:40 PM

Post #1 of 2 (306 views)
Shortcut
Samsung UA75JU6400WXXY - dark side of screen Can't Post

Hello all.

Im attempting to diagnose a tv fault but have limited knowledge in tv repairs.

Ive acquired a 75" samsung tv. It has a display issue in which half the screen is very dark. It almost seems like a backlight led issue but I can see some horizontal lines there as well which is throwing me off a little. From what I could see without pulling apart the actual display, all the backlight led chips appear to have light. Ive removed, cleaned and re-terminated the ribbon cables ive marked in my photo as per a few different suggestions online.

I know very little about TV repair but I know little about circuits and electronics (im a electrician by trade). Im happy to try a few suggestions if its fairly cheap fix like buying new ribbon cables or maybe a replacement board but if its going to cost several hundred dollars, i wont bother.

Any help would be appreciated. See photos in links.

https://1drv.ms/...KB6vHzDaQRw?e=2ZXN3G

https://1drv.ms/...11N6p24_WLg?e=npoDvR

https://1drv.ms/...YShCrBYDByA?e=jhLOvj

https://1drv.ms/...HI0tCfa2hWQ?e=oQd8gD

https://1drv.ms/...UTEpeLsz1RA?e=Dhrq8J

https://1drv.ms/...kUyQ5c8l0rA?e=FzKxKp



extremetvparts
New User

Oct 28, 2021, 10:33 AM

Post #2 of 2 (125 views)
Shortcut
Re: [MC89] Samsung UA75JU6400WXXY - dark side of screen [In reply to] Can't Post

If you need parts for your television, please try this guy on Ebay; he also has a new website for diagnosing televisions that anyone can understand, so take a look.
https://www.ebay.com.au/str/extremetvparts

https://sites.google.com/view/extreme-tv-parts/home?authuser=0

 
 
 


Search for (options) - Page loaded in: 0.20 s on (CGI/1.1)