TV Forums

Free Games Games Forums Music Forums TV Forums

  Main Index FORUM
HOME
Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN
Rules & FAQ RULES
F.A.Q.

Crumbtrail TV Forums: TV Equipment: LCD TV Forum:
Toshiba 32hl67us with sound no picture

 

 


harleyrider1970
New User

Feb 9, 2010, 5:03 PM

Post #1 of 20 (8038 views)
Shortcut
Toshiba 32hl67us with sound no picture Can't Post

My 32hl67 powers up and has sound. The picture comes on for a second and then goes black. A few seconds later it does this one more time. The sound works the entire time. Is this a bad back light inverter board? Any information will be greatly appreciated.....thanks.



techchris
Veteran

Feb 9, 2010, 6:36 PM

Post #2 of 20 (8030 views)
Shortcut
Re: [harleyrider1970] Toshiba 32hl67us with sound no picture [In reply to] Can't Post

have a look in the back of the screen to see if the backlights go out. If yes the fault is either the inverter board or the screen itself with the lights built in


jts1957
Veteran


Feb 9, 2010, 9:28 PM

Post #3 of 20 (8027 views)
Shortcut
Re: [harleyrider1970] Toshiba 32hl67us with sound no picture [In reply to] Can't Post

When screen is dark and sound is playing - While shining a flashlight close to screen, can you see any very dim images? Turn off lights in the room and observe from various angles.


-------------------------
Location: Far, Far Away


harleyrider1970
New User

Feb 9, 2010, 10:24 PM

Post #4 of 20 (8024 views)
Shortcut
Re: [jts1957] Toshiba 32hl67us with sound no picture [In reply to] Can't Post

Yes I tried looking at the screen in a dark room with a flaslight. I can't see any dim images. The sound can still be heard.


jts1957
Veteran


Feb 10, 2010, 12:47 AM

Post #5 of 20 (8022 views)
Shortcut
Re: [harleyrider1970] Toshiba 32hl67us with sound no picture [In reply to] Can't Post

If true, then inverter/lamps are unlikely cause.Cool


-------------------------
Location: Far, Far Away


harleyrider1970
New User

Feb 10, 2010, 1:38 AM

Post #6 of 20 (8019 views)
Shortcut
Re: [jts1957] Toshiba 32hl67us with sound no picture [In reply to] Can't Post

I am gonna check with a flashlight in a darkroom one more time. I don't have a coax hooked up so it was only static for a sec before going black. I was able to hit the menu button and see it before it went black. Point is I'm not sure when I did check for a dim picture, if I still had the menu up. If not, I might not have seen just static. If I have the same result, I guess I'll try to figure out where it comes off the power supply board and see if I'm getting the 24volts consistently. Thanks for all your help by the way.


harleyrider1970
New User

Feb 10, 2010, 12:12 PM

Post #7 of 20 (8014 views)
Shortcut
Re: [harleyrider1970] Toshiba 32hl67us with sound no picture [In reply to] Can't Post

I just hooked up my DVD player and found a dim picture with a flashlight. I guess it's either the backlight inverter board or a bad lamp. I will now take it apart further to check. If it's the inverter board number I think it is, there is one on eBay for $59. I'm no tv repairman but if it is the board, I'm gonna check to see if I can test the board for bad components. I'm an electrician so I know how to test transformers, resistors, capacitors, diodes, etc. I'll keep you posted... Thanks so much for the flashlight trick. I wouldn't have thought of it.


jts1957
Veteran


Feb 11, 2010, 12:21 AM

Post #8 of 20 (8010 views)
Shortcut
Re: [harleyrider1970] Toshiba 32hl67us with sound no picture [In reply to] Can't Post

Now unplug (I'm assuming they DO unplug individually) ALL (except one) of the bulb plug-in connectors. See if there is a white light flash on the screen and then goes dark, if so unplug bulb connector and move to the next. Repeat until all have been tried.
If one (or more) fail to produce a white light flash, you've most likely discovered a defective bulb or bad inverter "channel."Smile


-------------------------
Location: Far, Far Away


harleyrider1970
New User

Feb 11, 2010, 2:07 PM

Post #9 of 20 (8007 views)
Shortcut
Re: [jts1957] Toshiba 32hl67us with sound no picture [In reply to] Can't Post

I checked voltage where it comes into the inverter board and that was ok. Then i checked the board itself. The backlight inverter board only has voltage on a portion of the board and no output voltage to the lamps. I ordered one off ebay for $50 with free shipping. Thanks for all the help.


jts1957
Veteran


Feb 11, 2010, 3:30 PM

Post #10 of 20 (8005 views)
Shortcut
Re: [harleyrider1970] Toshiba 32hl67us with sound no picture [In reply to] Can't Post


Quote
My 32hl67 powers up and has sound. The picture comes on for a second and then goes black. A few seconds later it does this one more time. The sound works the entire time. Is this a bad back light inverter board? Any information will be greatly appreciated.....thanks.


Huh?Shocked If they light "for a second" they have to have ALL necessary voltages "for a second."

I'd monitor each of the voltages where it comes into the inverter board. Main B-Plus should be supplied (and "stay" - from Power Supply); An enable or turn on voltage should also be supplied (and "stays" - from "control/logic" board).


-------------------------
Location: Far, Far Away


harleyrider1970
New User

Feb 11, 2010, 3:38 PM

Post #11 of 20 (8001 views)
Shortcut
Re: [jts1957] Toshiba 32hl67us with sound no picture [In reply to] Can't Post

Yes im sure there was voltage in order for the lamps to light up for a second. I have checked pins 1-5 positive and 6-10 negative where it comes into the backlight inverter board. Voltage is fine there. I don't have a schematic on the board but found only a portion of the board has voltage once the lamps fail. So i believe the problem is the backlight invertor board because i have proper input voltage to the board but no output once the lamps fail.


jts1957
Veteran


Feb 11, 2010, 3:50 PM

Post #12 of 20 (7999 views)
Shortcut
Re: [harleyrider1970] Toshiba 32hl67us with sound no picture [In reply to] Can't Post

O.K. - so you have Main B-Plus reaching inverter board.

What about the "Enable," "Inverter On/Off," "Control" signal, whichever you want to call it? (usually around 5 volts)Wink


-------------------------
Location: Far, Far Away


harleyrider1970
New User

Feb 11, 2010, 3:52 PM

Post #13 of 20 (7997 views)
Shortcut
Re: [jts1957] Toshiba 32hl67us with sound no picture [In reply to] Can't Post

Yes i have a constant 3.8 volts on the enable to the board.


jts1957
Veteran


Feb 11, 2010, 3:55 PM

Post #14 of 20 (7995 views)
Shortcut
Re: [harleyrider1970] Toshiba 32hl67us with sound no picture [In reply to] Can't Post

Defective inverter board (or bulb(s)).


-------------------------
Location: Far, Far Away


harleyrider1970
New User

Feb 11, 2010, 3:59 PM

Post #15 of 20 (7991 views)
Shortcut
Re: [jts1957] Toshiba 32hl67us with sound no picture [In reply to] Can't Post

I would have to think inverter board because with it unplugged from the lamps, i don't get any output voltage to where the lamps plug in. It does for only a couple seconds.


harleyrider1970
New User

Feb 11, 2010, 4:01 PM

Post #16 of 20 (7989 views)
Shortcut
Re: [harleyrider1970] Toshiba 32hl67us with sound no picture [In reply to] Can't Post

Oh yeah, i really want to thank you for all the help. Maybe once i get it fixed, i will try to fix another one. It's kind of fun. Ive always liked making things work.....thanks again!


jts1957
Veteran


Feb 11, 2010, 4:03 PM

Post #17 of 20 (7987 views)
Shortcut
Re: [harleyrider1970] Toshiba 32hl67us with sound no picture [In reply to] Can't Post

Inverter is a "balanced" circuit with plenty of feedback/safety. One bulb out, a bulb plug-in connector unplugged, etc. - shuts down circuit,Smile

I assume you get a picture for a moment EACH time the set is tried.


-------------------------
Location: Far, Far Away


harleyrider1970
New User

Feb 11, 2010, 4:13 PM

Post #18 of 20 (7985 views)
Shortcut
Re: [jts1957] Toshiba 32hl67us with sound no picture [In reply to] Can't Post

Yes i do get the picture for a second each time i turn on power. Hmmm i did not know this. So i better check the bulbs too. I have done a little research on the internet and i guess it's quite common for these boards to go bad. I hope that's the case with mine and not the bulbs...seeing i already ordered the board.


harleyrider1970
New User

Feb 13, 2010, 8:41 PM

Post #19 of 20 (7976 views)
Shortcut
Re: [harleyrider1970] Toshiba 32hl67us with sound no picture [In reply to] Can't Post

Live and learn. I replaced the backlight inverter board today and still no picture. So I checked the lamps and one had a small crack and a little black behind it. I removed it and it broke where the crack was. Now I'm looking online to find a replacement. I'm not having much luck finding one. Does anyone know where I can find one? The number on the cover is LTY320WT-LH2.


jts1957
Veteran


Feb 13, 2010, 9:43 PM

Post #20 of 20 (7976 views)
Shortcut
Re: [harleyrider1970] Toshiba 32hl67us with sound no picture [In reply to] Can't Post

If one is bad, remember they ALL have the same amount of hours/usage.
You may have to measure bulb (diameter & length) - should be able to obtain - Google replacement CCFL bulb(s)(700K "hits").


-------------------------
Location: Far, Far Away

 
 
 


Search for (options) - Page loaded in: 0.22 s on (CGI/1.1)