TV Forums

Free Games Games Forums Music Forums TV Forums

  Main Index FORUM
HOME
Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN
Rules & FAQ RULES
F.A.Q.

Crumbtrail TV Forums: TV Equipment: LCD TV Forum:
Samsung 60" backlight, sound, no picture

 

 


Berganza
New User

Jan 21, 2016, 2:43 AM

Post #1 of 2 (1091 views)
Shortcut
Samsung 60" backlight, sound, no picture Can't Post

I have a Samsung 60" smart TV that has sound, backlight, but no picture (looks black). I have tried unplugging for days, clicking menu/etc/etc on the remote with no luck. Most forums indicated bad T-con board, so I bought a brand new T-Con board and installed. I'm having the exact same issue on new T-Con board.

What else could be the problem?



jts1957
Veteran


Jan 21, 2016, 3:52 AM

Post #2 of 2 (1090 views)
Shortcut
Re: [Berganza] Samsung 60" backlight, sound, no picture [In reply to] Can't Post

Both tcon boards may be defective.

Assuming 'Brand New' does NOT mean the SAME as 'New to You' to YOU. (There are many pulled from service/returned defective boards being sold as 'brand new.') Your new board will have either a Samsung company return address or one of their 'authorized' distributors. If the place was a ma/pa internet address, you may presume that it is (at least) pulled.

Otherwise, Main board.


-------------------------
Location: Far, Far Away

(This post was edited by jts1957 on Jan 21, 2016, 3:56 AM)

 
 
 


Search for (options) - Page loaded in: 0.16 s on (CGI/1.1)