TV Forums

Free Games Games Forums Music Forums TV Forums

  Main Index FORUM
HOME
Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN
Rules & FAQ RULES
F.A.Q.

Crumbtrail TV Forums: TV Equipment: TV Repair Forum:
60" Vizio E600i-b3 vertical box left side of screen

 

 


smp4488
New User

Sep 23, 2017, 3:57 PM

Post #1 of 3 (344 views)
Shortcut
60" Vizio E600i-b3 vertical box left side of screen Can't Post

I got a Vizio E600i-b3 from work for free because it was broken. The colors were off and I figured I could fix it. When I got it home, to my surprise, it worked fine. After a week the color issue returned. I googled around for solutions and found it could be the tcon board. I ordered one from shopjimmy.com. While I waited I went ahead and took the TV apart to get ready for the new board. I read about making sure the cables were seated correctly, but none of that helped. At one point I didn't realize the tv was plugged in while I was removing the ribbon cables on the tcon board. There is now a vertical box on the left side of the TV. The new tcon did fix the color issue, but I get the vertical box with either of the tcon board installed. My fear is that I fried part of the panel while messing with the ribbon cables. What are your alls thoughts? Pictures below.

I was thinking of ordering the full repair kit from shopjimmmy.com which includes the power, control, and tcon boards. I wanted to see what your alls thought were before I spent $60 on it.

https://i.imgur.com/buQC173.jpg
https://i.imgur.com/dU3F9dV.jpg


(This post was edited by smp4488 on Sep 23, 2017, 4:01 PM)



smp4488
New User

Sep 23, 2017, 5:27 PM

Post #2 of 3 (334 views)
Shortcut
Re: [smp4488] 60" Vizio E600i-b3 vertical box left side of screen [In reply to] Can't Post

A quick update. I put the old tcon board back in to test the LVDS cable and when I wiggle the LVDS connector on the control board and the color fixes itself. When I unplug it the screen goes black and the vertical bar fades away. I don't know if this helps at all.


smp4488
New User

Sep 28, 2017, 10:21 PM

Post #3 of 3 (288 views)
Shortcut
Re: [smp4488] 60" Vizio E600i-b3 vertical box left side of screen [In reply to] Can't Post

After unplugging the two ribbon cables on the tcon board going to the panel the screen in now all white. This makes me think the panel isn't bad, but I have no idea. With the LVDS cable unplugged the screen is backlit and all black

Do you all think the panel is bad?

(tcon disconnected from panel)https://imgur.com/gallery/Rn5IO


(This post was edited by smp4488 on Sep 29, 2017, 12:06 AM)

 
 
 


Search for (options) - Page loaded in: 0.16 s on (CGI/1.1)