TV Forums

Free Games TV Forums

  Main Index FORUM
HOME
Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN
Rules & FAQ RULES
F.A.Q.

Crumbtrail TV Forums: TV Equipment: TV Repair Forum:
Determined or hard headed

 

 


patd
New User

Mar 23, 2023, 12:59 AM

Post #1 of 1 (98 views)
Shortcut
Determined or hard headed Can't Post

Hello all and thanks in advance for any help.

Have a Sony XBR75x950H. In the middle of watching a program it just turned off just like someone pulled the plug or pressed the power button. Tried to restart with no success. Tried to do a hard reset and it would begin to boot up (showed the Android splash screen starting) but after about 20 seconds would turn off again. I would get 4 blinking lights.

I called Sony and they said that I needed a repair person but there was no authorized Sony repair center in my state. They advised me to get an independent repair person.

After spending almost $4K on this high-end TV less than 2 years ago I wanted to try to do something. I started by investigating the red blinking light. I am an amateur but after some research it appeared that perhaps my power board or main board had an issue.

I found a repair kit specifically for my TV with official new Sony parts and purchased it. All the numbers for the parts matched up perfectly. I was pretty sure it was the power board. After replacing the power board I had the same result. I ended up changing everything even if it didnít make any sense. Power board, tcon board, ld board, wireless board, main board, antenna and all the wiring were replaced. I also tested my power cord and tried multiple electrical outlets. On a side note the kit wasnít that expensive and it didnít really take long to do. The only things that werenít replaced was the screen and the speakers.

Almost seems like a software issue. Tried to boot and install firmware via usb but the TV doesnít stay on long enough.

I am stuck. Any advice on what could be the issue (with the TV)?


 
 
 


Search for (options) - Page loaded in: 0.19 s on (CGI/1.1)