TV Forums

Free Games Games Forums Music Forums TV Forums

  Main Index FORUM
HOME
Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN
Rules & FAQ RULES
F.A.Q.

Crumbtrail TV Forums: TV Equipment: TV Repair Forum:
Green screen of death? LG 47LG70

 

 


WestCoast
New User

Jul 13, 2015, 1:41 PM

Post #1 of 9 (992 views)
Shortcut
Green screen of death? LG 47LG70 Can't Post

UPDATE: here's a picture: [URL=http://s288.photobucket.com/user/WestCoastSuccess/media/Mobile%20Uploads/IMG_20150712_150607_zpswy96ijm2.jpg.html]

My 47 inch LG 47LG70 abruptly stopped working properly and instead now shows a green screen with a grey pixelated box in the left side, middle of screen vertically. The OSD doesn't display, the problem is not related to input sources (it remains present even when all inputs are disconnected from TV) and it is persistent - it does not resolve intermittently. Having taken the back off the unit, it does not appear that any cables are loose, and a cursory look at the capacitors doesn't show any bulging or leaking. I have a picture available but I'm afraid I can't see an option to include with this post.

I'm happy to provide any additional information and grateful for any help and suggestions.

Thank you.

(This post was edited by WestCoast on Jul 13, 2015, 7:57 PM)



jts1957
Veteran


Jul 13, 2015, 7:15 PM

Post #2 of 9 (985 views)
Shortcut
Re: [WestCoast] Green screen of death? LG 47LG70 [In reply to] Can't Post

http://www.tv-forums.com/...i?post=157911#157911


-------------------------
Location: Far, Far Away


WestCoast
New User

Jul 13, 2015, 7:59 PM

Post #3 of 9 (974 views)
Shortcut
Re: [jts1957] Green screen of death? LG 47LG70 [In reply to] Can't Post

Thanks - have updated my post with a picture accordingly.


jts1957
Veteran


Jul 13, 2015, 8:22 PM

Post #4 of 9 (970 views)
Shortcut
Re: [WestCoast] Green screen of death? LG 47LG70 [In reply to] Can't Post

In my mind this sounds like the TV has one Input selected and all Inputs are disconnected, which doesn't say anything about whether it is or is not present when EACH Input source is selected.

BTW, Ron.M may have a problem with the picture you posted. Wink


-------------------------
Location: Far, Far Away

(This post was edited by jts1957 on Jul 13, 2015, 8:23 PM)


WestCoast
New User

Jul 13, 2015, 8:32 PM

Post #5 of 9 (966 views)
Shortcut
Re: [jts1957] Green screen of death? LG 47LG70 [In reply to] Can't Post

Thanks. I assumed, perhaps incorrectly, that the OSD overlays the picture produced from a particular input, such that the OSD should appear correctly even where an input source produces a bad picture. In the image I posted above, there are no inputs attached at all. I can't tell which input is currently selected, since the OSD doesn't display, but I did try flying blind and selecting different inputs via the remote, with no change. It could well be that the OSD does work but is also garbled.


jts1957
Veteran


Jul 13, 2015, 9:32 PM

Post #6 of 9 (962 views)
Shortcut
Re: [WestCoast] Green screen of death? LG 47LG70 [In reply to] Can't Post

Is power LED lit when set is on?
NO audio?
Responds to remote? Power button works on set & on remote?
You've checked all power supply sources and they are correct?

Try reseating any pluggable FFCs for tcon. Burnish them while unplugged.
If your OSD appeared under your symptom (IS affected) it would likely be the tcon or panel - If your OSD appeared in front of your symptom (is Unaffected) it shouldn't be tcon or panel.


-------------------------
Location: Far, Far Away


WestCoast
New User

Jul 14, 2015, 2:12 AM

Post #7 of 9 (955 views)
Shortcut
Re: [jts1957] Green screen of death? LG 47LG70 [In reply to] Can't Post

Thanks - that's informative re: OSD.

Power LED is lit when set on.
Audio only produces static on 2 of the inputs when I cycle through the inputs (can't tell which, given I can't see the OSD) - I hooked it up to the cable box via HDMI and selected a channel (I think) - no audio.
TV responds to remote, and to buttons on set.
All power supply sources appear OK.
Have unplugged and cleaned T-con connections - no change.

Given your comments, is there any way to determine definitively if it's the t-con or the panel? The t-con I'd replace; the panel I won't, as I'm guessing it wouldn't be economical to do so.

Thanks again for all the help and suggestions - very much appreciate it.


jts1957
Veteran


Jul 14, 2015, 2:35 AM

Post #8 of 9 (953 views)
Shortcut
Re: [WestCoast] Green screen of death? LG 47LG70 [In reply to] Can't Post

Troubleshooting flow charts show details for Power supply to 2 main board chips, Tuner, each input, audio in/out. ALL of which would be on Main board, which is what my best guess at this point would be.

If you can put set on each of the 2 that have static and input a signal through antenna/cable (selecting a few over-the-air local stations) and the various audio inputs, using say the output of a CD player. I'm assuming one is tuner and other an analog input.


-------------------------
Location: Far, Far Away


spectre3ooo
New User

Jan 5, 2017, 4:50 PM

Post #9 of 9 (242 views)
Shortcut
Re: [WestCoast] Green screen of death? LG 47LG70 [In reply to] Can't Post

What did you end up doing with your TV? I have a 47LG70 that started doing the exact same thing.

 
 
 


Search for (options) - Page loaded in: 0.20 s on (CGI/1.1)