TV Forums

Free Games Games Forums Music Forums TV Forums

  Main Index FORUM
HOME
Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN
Rules & FAQ RULES
F.A.Q.

Crumbtrail TV Forums: TV Equipment: TV Repair Forum:
Insignia NS-46D40SNA14 backlight problem

 

 


yetimnstr
New User

Jan 1, 2017, 2:27 AM

Post #1 of 6 (260 views)
Shortcut
Insignia NS-46D40SNA14 backlight problem Can't Post

I did some reading and was able to determine that my TV had a problem with the backlights. I did a flashlight test and determined in a dark room that the picture is there and I have audio. The backlight cycles when the TV is first turned on and displays the Insignia logo on the screen then goes (black) back off. I replaced the power supply/LED board as I thought it was the problem. It had a burned spot on the circuit board and based on some investigation I thought it was an all-in-one board that did the inverter function to light the backlights. After replacing the board the TV still does the same thing. Backlight only flashes at power up to display the logo again.

This TV only has 3 boards visible inside the main backcover. There is the main board, the power supply/LED board and the T-Con board. Based on what I read it doesn't sound like my T-Con board or main board are bad, but since I replaced the only other board left I am not sure where to go next.

Anyone have any advice on what to look at next. I appreciate any advice or guidance you can provide. I hate to scrap this TV if it is fixable for a reasonable investment. Thanks in advance.



jts1957
Veteran


Jan 1, 2017, 1:01 PM

Post #2 of 6 (252 views)
Shortcut
Re: [yetimnstr] Insignia NS-46D40SNA14 backlight problem [In reply to] Can't Post

One or the other:
EEPROM (Main Board);{Symptoms EEPROM replacement MAY fix: - TV turns on but there is no backlight (LED indicator shows TV is on but there is no image)(They don't specify as to sound)}

or

Defective LED(s) in the panel (LEDs don't seem to be lasting anywhere near their design specifications). (Shorted LED(s) drives UL1 too hard & it gets very hot and shuts down the set).


-------------------------
Location: Far, Far Away

(This post was edited by jts1957 on Jan 1, 2017, 1:08 PM)


yetimnstr
New User

Jan 1, 2017, 10:01 PM

Post #3 of 6 (230 views)
Shortcut
Re: [jts1957] Insignia NS-46D40SNA14 backlight problem [In reply to] Can't Post

Thanks for the advice. I did some more reading after reading your post to see if I can find a replacement main board and I found other references to the EEPROM related to the backlight not starting. I think this is the direction I am going to follow next. I tried turning the TV on with the backcover off in the dark and the backlights all seem to light briefly when powering the TV on. It is only for about a second while the TV displays the logo but after trying it several times I am confident they are lighting okay. I think it must be the instruction set is corrupted in the EEPROM and it is not sending the signal to turn the backlights on after the TV is powered up.

I am trying to determine which way to go with the mainboard now. In looking for the replacement I found where I can purchase just the EEPROM and replace that but I am not sure about the model code on the board. The mainboard on my TV is 55.46S16.ME1 and I found one listing on eBay for this same part number. I also found several other listings for boards with ME3 in the model code label. I also found listings for just the EEPROM to repair my existing mainboard, but they reference the model code needing to match ME2. The ME1 and ME3 boards look identical and it seems like this is just a revision number. My question at this point is would the EEPROM replacement work on my ME1 board since it references needing to be ME2 and/or would I be able to just buy an ME3 board and have it work on my TV if that is a cheaper option. The rest of the referenced code matches up with my existing as above. If any of you can provide clarity or guidance that would be great.


jts1957
Veteran


Jan 1, 2017, 10:32 PM

Post #4 of 6 (226 views)
Shortcut
Re: [yetimnstr] Insignia NS-46D40SNA14 backlight problem [In reply to] Can't Post


Quote
Part number 55.46S16.ME2 is found within serial number printed on barcode sticker on board?



-------------------------
Location: Far, Far Away


yetimnstr
New User

Jan 1, 2017, 10:51 PM

Post #5 of 6 (223 views)
Shortcut
Re: [jts1957] Insignia NS-46D40SNA14 backlight problem [In reply to] Can't Post

Yes, but the board on my TV has 55.46S16.ME1 as part of the barcode sticker. The actual part number on the board is 48.46S11.M04 but it was on the shopjimmy.com website where I was looking at the EEPROM and they referenced the other part number from the barcode sticker and specifically that it should be ME2 in order to use the EEPROM chip they are selling.


jts1957
Veteran


Jan 1, 2017, 11:40 PM

Post #6 of 6 (221 views)
Shortcut
Re: [yetimnstr] Insignia NS-46D40SNA14 backlight problem [In reply to] Can't Post

http://www.shopjimmy.com/...esult/?q=55.46S16.ME

Note that SJ ONLY shows a 'ME2' variant. Other sites show the others. I'd stick with 'exact' number. Also as I mentioned before, SJ is NOT saying whether audio is present.


Quote
I tried turning the TV on with the backcover off in the dark and the backlights all seem to light briefly when powering the TV on. It is only for about a second while the TV displays the logo but after trying it several times I am confident they are lighting okay.

Unless you have seen each and every panel LED lighting, I'd still keep them as suspect.


-------------------------
Location: Far, Far Away

 
 
 


Search for (options) - Page loaded in: 0.19 s on (CGI/1.1)