TV Forums

Free Games Games Forums Music Forums TV Forums

  Main Index FORUM
HOME
Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN
Rules & FAQ RULES
F.A.Q.

Crumbtrail TV Forums: TV Equipment: TV Repair Forum:
Panasonic TX-50CX680B picture upside down after replacing main board

 

 


IainG
New User

Jul 30, 2020, 11:37 AM

Post #1 of 2 (290 views)
Shortcut
Panasonic TX-50CX680B picture upside down after replacing main board Can't Post

Hello all,

Our Panasonic TV (TX-50CX680B) wouldn't power on (after a lightning strike took out our phone line, router and TV via the ethernet cable) I diagnosed that the main board had blown so got one online and replaced it (TNPH1120 2A). TV now powers up and functions fine other than the fact the picture is upside down (rotated 180 degrees... i.e you can still read the menus etc if you were doing a hand stand!).

I tried accessing the service menu and discovered that pressing vol- on the TV and pressing red 3 times brought up "CS Maintenance Menu" but nothing there looks helpful. Is there a different button combination for accessing the actual service menu? Saw online some TV's have an "invert image" setting in the hidden service menu.

Any advice is appreciated.

Thank you,
Iain



IainG
New User

Aug 13, 2020, 5:40 PM

Post #2 of 2 (241 views)
Shortcut
Re: [IainG] Panasonic TX-50CX680B picture upside down after replacing main board [In reply to] Can't Post

To answer my own question, you have to make sure you have the correct replacement main board and check both the main board part number and also the TXN which is TXN/A1JQVB in my case (this is printed on a label stuck to the main board). I expect this relates to what firmware is loaded on the board and in turn what model of TV it will work on. I didn't realise this and had the 55" version in my 50". Funny how it still worked but was upside down.

Anyway, I got there in the end and the TV was saved from the skip! Was 650 new and only cost 40 to fix so well worth the effort.

 
 
 


Search for (options) - Page loaded in: 0.39 s on (CGI/1.1)