TV Forums

Free Games Games Forums Music Forums TV Forums

  Main Index FORUM
HOME
Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN
Rules & FAQ RULES
F.A.Q.

Crumbtrail TV Forums: TV Equipment: TV Repair Forum:
Vizio E70-C3 Repair Help

 

 


kaeden1100
New User

Dec 16, 2019, 3:43 AM

Post #1 of 2 (135 views)
Shortcut
Vizio E70-C3 Repair Help Can't Post

Hey guys new to the forum and new to repairing TV's alltogether. I've built PC's and such for years so I've got a little experience with electronics, but from what I've gathered TV's are a sort of whole different monster.

I have a Vizio E70-C3 70" TV I've been trying to repair. We got the TV as a hand me down from a family member and when we got the TV it had a small (Like 1px Wide) vertical line that went down the right side of the tv. The line was red and dotted. I did a little research online and found that I could try applying pressure to the ribbon cables connecting the display to the T-Con Board and it may make the line disappear. So I attempted this and I feel that it's worth mentioning while I had the TV on so that I could see if the line was going away, meanwhile I was trying to reach around the backside of the TV and apply pressure, I touched something on the power supply board, shocking myself. I'm not sure if I could've damaged the board somehow by touching it or not but I thought that might be worth mentioning. After putting pressure on the ribbon cables did nothing, I decided that it may be worth trying to replace the T-Con board considering I could get one so cheaply. So I ordered one and tried that. And that obviously didn't fix it (or I wouldn't be here). It actually made the problem even worse. I've now messed around with flipping the ribbon cables around to see if maybe that fixed it, and nothing. I'm out of ideas. I'm honestly at this point starting to think that somehow the panel is now damaged. I've attached a picture of the TV in it's current state when it's on and that's all I've got.

Keep in mind, when the first issue was there (the red line) the image was still perfectly fine and visible on the TV. Now, I have no image at all. Just the new effects on the display shown in the image.

So I'm at a loss and honestly just considering scrapping the TV but I figured I'd give this forum a shot to see if maybe I was just missing something. So if anyone has any ideas at all, please let me know.

https://drive.google.com/file/d/1rLXrMPSXHX0nyCTMEL7qWPu_FhANUuqt/view?usp=sharing



jts1957
Veteran


Dec 18, 2019, 1:10 PM

Post #2 of 2 (117 views)
Shortcut
Re: [kaeden1100] Vizio E70-C3 Repair Help [In reply to] Can't Post

Your original symptom was likely related to a 'tab bond' inside the panel. Tcon connects to driver boards, driver boards connect through 'tabs' to the TFT glass panel itself. (You would usually have to partially disassemble the panel to access.) SEE: https://ibb.co/kgd9J7j

Unless you have access to a replacement panel, I'd scrap it.


-------------------------
Location: Far, Far Away

 
 
 


Search for (options) - Page loaded in: 0.24 s on (CGI/1.1)