TV Forums

Free Games Games Forums Music Forums TV Forums

  Main Index FORUM
HOME
Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN
Rules & FAQ RULES
F.A.Q.

Crumbtrail TV Forums: TV Equipment: TV Repair Forum:
Samsung PS51D450 Xmain Question

 

 


jamesb79
New User

Apr 15, 2021, 7:02 PM

Post #1 of 1 (89 views)
Shortcut
Samsung PS51D450 Xmain Question Can't Post

I have a PS51D450 it's been working perfect until last week, where it turned off and I had no picture or sound. I discovered a short on the X main board, all other board test fine, giving me proper voltages across them. I replaced the x main last night and the TV works again. Picture is near perfect. When I checked th VE test point on the X main Iam only getting 86 volts but the ribbon cable coming from the Y main is giving it 100 volts which is close to what the panel sticker states for VE 101 volts.

Because the TV is working again, I have switched it back off incase it does any damage until I find out if I need to adjust the bottom pot so the VE test point on the X Main should be set to read 101v instead of 86v, why is it reading 86v at the VE test point when it is getting 100v from the y main will this damage the board?

Also I noticed there is some amount of heat from the big heatsink on the X main so much that after only 10 mins you can't keep your finger on the heatsink is this normal? I know to TV gave off a lot of heat before so this might be normal but thought I would ask. Should it be this hot?

Thanks


(This post was edited by jamesb79 on Apr 16, 2021, 8:01 AM)


 
 
 


Search for (options) - Page loaded in: 0.40 s on (CGI/1.1)